All systems operational

Issue with Email Hosting

Resolved
Minor outage
Started about 3 years ago Lasted 7 minutes

Affected

Servers
Mail Server
Services
IMAP
SMTP
Email Service
Updates
  • Resolved
    Resolved

    We just resolved the issue!

  • Identified
    Identified

    The issue with Email Hosting has been fixed. This outage has now been resolved

  • Investigating
    Investigating

    We are currently investigating an issue with our Email Hosting services. The email server is down and our techs are working on the issue and we will update with solutions.